summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:13:09 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:36 +0200
commit07c3711d0fdaae8cdd3e6a466b48b98add251918 (patch)
tree9727b3b811e8cab051661a902ee9a4cb2983d38e /gnu/packages/ocaml.scm
parentf6a99fbfa22f45ba8f1f9e13b45bc5017138243e (diff)
gnu: ocaml-re: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-re)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5272d9fbca..f341039461 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3558,14 +3558,15 @@ standard iterator type starting from 4.07.")
(package
(name "ocaml-re")
(version "1.8.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ocaml/ocaml-re//archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1pdb0mr6z5ax6szblr3f5lbdnqq9grm97cmsfjmdma60yrx2rqhd"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/ocaml-re.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ch6hvmm4ym3w2vghjxf3ka5j1023a37980fqi4zcb7sx756z20i"))))
(build-system dune-build-system)
(arguments
`(#:tests? #f