summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:10:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:08 +0200
commit71117a36b6b79bc906e396a13e0177281b6c3524 (patch)
treed3b423f9f95682ed192d13e18441b6dcb2821a13 /gnu/packages/ocaml.scm
parentef59cf9d3bf64086fda1b0fe205210e9a36d60a0 (diff)
gnu: ocaml4.02-ppx-tools: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml4.02-ppx-tools)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0d5ec46da4..b593a75df9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1972,12 +1972,13 @@ simple (yet expressive) query language to select the tests to run.")
(inherit base)
(version "5.0+4.02.0")
(source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/alainfrisch/ppx_tools/archive/"
- version ".tar.gz"))
- (sha256 (base32
- "0rjg4rngi8k9873z4zq95zn9hj8qyw1vcrf11y15aqasfpqq16rc")))))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alainfrisch/ppx_tools.git")
+ (commit version)))
+ (sha256
+ (base32 "16drjk0qafjls8blng69qiv35a84wlafpk16grrg2i3x19p8dlj8")))))))
(define-public ocaml-react
(package