summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:10:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:32:52 +0200
commitb01339816ac986adce6e9fc9cf229364b2e62650 (patch)
tree512d580a0df3cf974a61d3df270a6f5b155d61a9 /gnu/packages/ocaml.scm
parent34f615a2c167660075d81c09621dd030122393b9 (diff)
gnu: ocaml-qcheck: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-qcheck)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 79c6a990c3..eb20dfb98f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1270,14 +1270,15 @@ GNU CC attributes. It provides also a C pretty printer as an example of use.")
(package
(name "ocaml-qcheck")
(version "0.5.3.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/c-cube/qcheck/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1zs1pg5cb1iry554v3cdmmiglsrwmsqa9x8zxmzb118fnk5d3ha6"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/c-cube/qcheck.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vl2asr7md99pv558nbszxvjj36b4l6rj05hyczfy524vihhl0gf"))))
(build-system ocaml-build-system)
(native-inputs
`(("ounit" ,ocaml-ounit)