summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:08:53 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:32:51 +0200
commitd5dee1de7c8c330ccdcb2538f9d2a22ae5d64d6b (patch)
treeab51aacd2c8f6309684f26b355e447b67e4142dd /gnu/packages/ocaml.scm
parent93b3dc523ef79215f9ac0a26c968770db689f5f0 (diff)
gnu: camlp4@4.02+6: Don't use unstable tarball.
* gnu/packages/ocaml.scm (camlp4-4.02)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 58746d45df..9fcd0048fd 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -564,14 +564,15 @@ Git-friendly development workflow.")
(package
(name "camlp4")
(version "4.02+6")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ocaml/camlp4/archive/"
- version ".tar.gz"))
- (sha256
- (base32
- "0icdfzhsbgf89925gc8gl3fm8z2xzszzlib0v9dj5wyzkyv3a342"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/camlp4.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06yl4q0qazl7g25b0axd1gdkfd4qpqzs1gr5fkvmkrcbz113h1hj"))))
(build-system gnu-build-system)
(native-inputs `(("ocaml" ,ocaml-4.02)
("which" ,which)))