summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:10:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:32:52 +0200
commite3c7ac732f81dee2e35a6c8b69423d9d20d7af81 (patch)
treebc0d152ce45596657ae778cd42a4b050aba586f5 /gnu/packages/ocaml.scm
parentb01339816ac986adce6e9fc9cf229364b2e62650 (diff)
gnu: ocaml-bisect: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-bisect)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index eb20dfb98f..338dbb8db4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1362,17 +1362,18 @@ full_split, cut, rcut, etc..")
(package
(name "ocaml-bisect")
(version "1.3.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/gasche/bisect/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0p67fppk5ifb63b00kxwrb1xg75hrqhknng3bsdyw3gxxqyjlpmx"))
- (patches
- (search-patches
- "ocaml-bisect-fix-camlp4-in-another-directory.patch"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gasche/bisect.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hm5za61qydda6ri3887b4zqqbqilh42x712xnclm1rr7ggga2nh"))
+ (patches
+ (search-patches
+ "ocaml-bisect-fix-camlp4-in-another-directory.patch"))))
(build-system ocaml-build-system)
(native-inputs
`(("camlp4" ,camlp4)