summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:13:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:36 +0200
commite4bb29ddfab558dc9fdc28a4ac2b80bd1d65e5b5 (patch)
tree111ccd193c430d9ad2b0e50cd6966e44506ce0a3 /gnu/packages/ocaml.scm
parent21b1845ddeb33624140711260029d166d1f20b07 (diff)
gnu: ocaml4.02-uri: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml4.02-uri)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3b44e7e9f2..dd1b658085 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3978,14 +3978,15 @@ JSON.")
(package
(name "ocaml4.02-uri")
(version "1.9.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mirage/ocaml-uri/archive/v"
- version ".tar.gz"))
- (sha256
- (base32
- "02bzrag79prx261rxf9mlak749pwf4flpfl8p012x1xznv9m0clc"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/ocaml-uri.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "137pg8j654x7r0d1664iy2zp3l82nki1kkh921lwdrwc5qqdl6jx"))))
(build-system ocaml-build-system)
(arguments
`(#:ocaml ,ocaml-4.02