summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:13:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:22 +0200
commitf6a99fbfa22f45ba8f1f9e13b45bc5017138243e (patch)
tree02a1ac9f6b13bcd06bda2e6481977a9b47936196 /gnu/packages/ocaml.scm
parent2209b362a5fe39cff5d0950938d7a913c8c08caf (diff)
gnu: ocaml-seq: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-seq)[source]: Use GIT-FETCH and GIT-FILE-NAME. Fix indentation.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d7b2eeee87..5272d9fbca 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3508,14 +3508,15 @@ new record values.")
(package
(name "ocaml-seq")
(version "0.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/c-cube/seq/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "02lb2d9i12bxrz2ba5wygk2bycan316skqlyri0597q7j9210g8r"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/c-cube/seq.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cjpsc7q76yfgq9iyvswxgic4kfq2vcqdlmxjdjgd4lx87zvcwrv"))))
(build-system ocaml-build-system)
(arguments
`(#:tests? #f
@@ -3534,9 +3535,9 @@ new record values.")
version=\"[distributed with ocaml]\"
description=\"dummy package for compatibility\"
requires=\"\"")))
- #t))))))
+ #t))))))
(properties
- `((ocaml4.02-variant . ,(delay ocaml4.02-seq))))
+ `((ocaml4.02-variant . ,(delay ocaml4.02-seq))))
(home-page "https://github.com/c-cube/seq")
(synopsis "OCaml's standard iterator type")
(description "This package is a compatibility package for OCaml's