summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 17:57:21 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:33:37 +0100
commitdb67f56901fcb5b365281dd726ed9c06c993e054 (patch)
tree546a0ceb6cc10fb673e68274b772f206cc5db20e /gnu/packages/ocaml.scm
parent6692f652182314eeeab4aad634084ec60d81f035 (diff)
gnu: Add ocaml-ppx-enumerate.
* gnu/packages/ocaml.scm (ocaml-ppx-enumerate): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f01eb37ad7..78f26b4f6d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5434,3 +5434,31 @@ storage of large amounts of data.")
(description "This package is a collecton of ppx rewriters that generate
hash functions from type exrpessions and definitions.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-enumerate
+ (package
+ (name "ocaml-ppx-enumerate")
+ (version "0.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_enumerate.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0spx9k1v7vjjb6sigbfs69yndgq76v114jhxvzjmffw7q989cyhr"))))
+ (build-system dune-build-system)
+ (arguments
+ ;; No tests
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_enumerate")))
+ (home-page "https://github.com/janestreet/ppx_enumerate")
+ (synopsis "Generate a list containing all values of a finite type")
+ (description "Ppx_enumerate is a ppx rewriter which generates a definition
+for the list of all values of a type (for a type which only has finitely
+many values).")
+ (license license:asl2.0)))