summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 13:06:40 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-31 21:35:42 +0100
commit5eed45a8d7c991513495a90f647bdc9ca36cf444 (patch)
treec76679fdd4d4ae3b3034f5f0ad089e4bad433f18 /gnu/packages/ocaml.scm
parent77a515e9b547dd0a137e1e37bdc3e0a35058b2e2 (diff)
gnu: Add ocaml-oasis.
* gnu/packages/ocaml.scm (ocaml-oasis): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9907d65fe0..2e00af009a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1900,3 +1900,45 @@ can match the question using a regular expression or a timeout.")
(description "Library to provide pure OCaml functions to manipulate real
file (POSIX like) and filename.")
(license license:lgpl2.1+))) ; with the OCaml static compilation exception
+
+(define-public ocaml-oasis
+ (package
+ (name "ocaml-oasis")
+ (version "0.4.8")
+ (source (origin
+ (method url-fetch)
+ (uri (ocaml-forge-uri name version 1669))
+ (sha256
+ (base32
+ "1ln7vc7ip6s5xbi20mhnn087xi4a2m5vqawx0703qqnfkzhmslqy"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "test/test-main/Test.ml"
+ ;; most of these tests fail because ld cannot find crti.o, but according
+ ;; to the log file, the environment variables {LD_,}LIBRARY_PATH
+ ;; are set correctly whene LD_LIBRARY_PATH is defined beforhand.
+ (("TestBaseCompat.tests;") "")
+ (("TestExamples.tests;") "")
+ (("TestFull.tests;") "")
+ (("TestPluginDevFiles.tests;") "")
+ (("TestPluginInternal.tests;") "")
+ (("TestPluginOCamlbuild.tests;") "")
+ (("TestPluginOMake.tests;") "")))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("ocamlify" ,ocamlify)
+ ("ocamlmod" ,ocamlmod)
+ ("ounit" ,ocaml-ounit)
+ ("omake" ,omake)
+ ("ocaml-expect" ,ocaml-expect)
+ ("ocaml-pcre" ,ocaml-pcre)
+ ("ocaml-fileutils" ,ocaml-fileutils)
+ ("camlp4" ,camlp4)
+ ("texlive" ,texlive)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://oasis.forge.ocamlcore.org")
+ (synopsis "Integrates a configure, build, install system in OCaml projects")
+ (description "OASIS is a tool to integrate a configure, build and install
+system in your OCaml projects. It helps to create standard entry points in your
+build system and allows external tools to analyse your project easily.")
+ (license license:lgpl2.1+))) ; with ocaml static compilation exception