summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 11:15:19 +0100
committerDavid Craven <david@craven.ch>2017-01-04 17:41:10 +0100
commit3d598ebd35f4890e5bb1490b1ba9175d5d46fc06 (patch)
tree20f2464f464678e3d5c266e8d7de1216825b42b4 /gnu/packages/ocaml.scm
parent0472836fcea71cce94128833497aed59fbc972d8 (diff)
gnu: Add ocaml-stringext.
* gnu/packages/ocaml.scm (ocaml-stringext): New variable. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b7cec588e7..0a362b1f92 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -937,3 +937,26 @@ syntax in comments. Those tests are then run using the oUnit framework and the
qcheck library. The possibilities range from trivial tests -- extremely simple
to use -- to sophisticated random generation of test cases.")
(license license:lgpl3+)))
+
+(define-public ocaml-stringext
+ (package
+ (name "ocaml-stringext")
+ (version "1.4.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rgrinberg/stringext"
+ "/archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "19g6lfn03iki9f8h91hi0yiqn0b3wkxyq08b3y23wgv6jw6mssfh"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("qtest" ,ocaml-qtest)))
+ (home-page "https://github.com/rgrinberg/stringext")
+ (synopsis "Extra string functions for OCaml")
+ (description "Provides a single module named Stringext that provides a grab
+bag of often used but missing string functions from the stdlib. E.g, split,
+full_split, cut, rcut, etc..")
+ ;; the only mention of a license in this project is in its `opam' file
+ ;; where it says `mit'.
+ (license license:expat)))