summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-08-22 12:28:09 -0500
committerEric Bavier <bavier@member.fsf.org>2016-08-22 23:59:54 -0500
commit4533cd73ef608fa88f2ccb765ce46441505c298a (patch)
treed09cb0e98143eec5e37f17afbc462a92313fb0ab /gnu/packages/ocaml.scm
parent2385cab1642ca974f4f892305c956277ee0d9341 (diff)
gnu: opam: Upgrade to 1.2.2.
* gnu/packages/ocaml.scm (opam): Upgrade to 1.2.2. [arguments]: define SHELL in #:make-flags. Build dependencies in 'pre-build phase. [inputs]: Add camlp4.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index de2ac7cc97..1f4c3e471a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -149,7 +149,7 @@ functional, imperative and object-oriented styles of programming.")
(define-public opam
(package
(name "opam")
- (version "1.1.1")
+ (version "1.2.2")
(source (origin
(method url-fetch)
;; Use the '-full' version, which includes all the dependencies.
@@ -161,7 +161,7 @@ functional, imperative and object-oriented styles of programming.")
)
(sha256
(base32
- "1frzqkx6yn1pnyd9qz3bv3rbwv74bmc1xji8kl41r1dkqzfl3xqv"))))
+ "004gwn6rbpcb53y3rpb3v23vk39rp2xmf0liyd5iy12ij8bigrhm"))))
(build-system gnu-build-system)
(arguments
'(;; Sometimes, 'make -jX' would fail right after ./configure with
@@ -169,7 +169,10 @@ functional, imperative and object-oriented styles of programming.")
#:parallel-build? #f
;; For some reason, 'ocp-build' needs $TERM to be set.
- #:make-flags '("TERM=screen")
+ #:make-flags `("TERM=screen"
+ ,(string-append "SHELL="
+ (assoc-ref %build-inputs "bash")
+ "/bin/sh"))
#:test-target "tests"
;; FIXME: There's an obscure test failure:
@@ -182,7 +185,9 @@ functional, imperative and object-oriented styles of programming.")
(let ((bash (assoc-ref inputs "bash")))
(substitute* "src/core/opamSystem.ml"
(("\"/bin/sh\"")
- (string-append "\"" bash "/bin/sh\""))))))
+ (string-append "\"" bash "/bin/sh\"")))
+ ;; Build dependencies
+ (zero? (apply system* "make" "lib-ext" make-flags)))))
(add-before 'check 'pre-check
(lambda _
(setenv "HOME" (getcwd))
@@ -190,7 +195,8 @@ functional, imperative and object-oriented styles of programming.")
(system "git config --global user.name Guix")))))))
(native-inputs
`(("git" ,git) ;for the tests
- ("python" ,python))) ;for the tests
+ ("python" ,python) ;for the tests
+ ("camlp4" ,camlp4)))
(inputs
`(("ocaml" ,ocaml)
("ncurses" ,ncurses)