summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-13 11:21:51 +0100
committerLudovic Courtès <ludo@gnu.org>2016-12-21 17:54:18 +0100
commit8afd19585f826e72197bc8775437f6d03ea8f813 (patch)
tree30cdbb81fe987cab8b2f77f6d54626cf5fac7ed2 /gnu/packages/ocaml.scm
parent054fea97b7559191aa95b152871fafe3c63c2992 (diff)
gnu: lablgtk: use ocamlfind in installation
* gnu/packages/ocaml.scm (lablgtk): Use ocamlfind in installation. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index bc9f8f8b87..555e3fdebe 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -507,6 +507,7 @@ Knuth’s LR(1) parser construction technique.")
(native-inputs
`(("camlp4" ,camlp4)
("ocaml" ,ocaml)
+ ("findlib" ,ocaml-findlib)
("pkg-config" ,pkg-config)))
;; FIXME: Add inputs gtkgl-2.0, libpanelapplet-2.0, gtkspell-2.0,
;; and gtk+-quartz-2.0 once available.
@@ -521,21 +522,24 @@ Knuth’s LR(1) parser construction technique.")
`(#:tests? #f ; no check target
;; opt: also install cmxa files
- #:make-flags (list "all" "opt")
+ #:make-flags (list "all" "opt"
+ (string-append "FINDLIBDIR="
+ (assoc-ref %outputs "out")
+ "/lib/ocaml"))
;; Occasionally we would get "Error: Unbound module GtkThread" when
;; compiling 'gtkThInit.ml', with 'make -j'. So build sequentially.
#:parallel-build? #f
#:phases
(modify-phases %standard-phases
- (replace 'install
+ (add-before 'install 'prepare-install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(ocaml (assoc-ref inputs "ocaml")))
;; Install into the output and not the ocaml directory.
+ (mkdir-p (string-append out "/lib/ocaml"))
(substitute* "config.make"
((ocaml) out))
- (system* "make" "old-install")
#t))))))
(home-page "http://lablgtk.forge.ocamlcore.org/")
(synopsis "GTK+ bindings for OCaml")