summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 11:40:26 +0100
committerDavid Craven <david@craven.ch>2017-01-04 17:41:11 +0100
commita359c7277c9243c6bea6963fc44b547f446fa7dd (patch)
tree0087b27bbef15628e6ea11516251b34ef4c388cd /gnu/packages/ocaml.scm
parent704b990c36b29bca681b1832e30c0901512b4f9a (diff)
gnu: Add ocaml-topkg.
* gnu/packages/ocaml.scm (ocaml-topkg): New variable. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9eff014993..d8c6fcf265 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1093,3 +1093,33 @@ powerful.")
staying compatible with older version of OCaml should use the Result module
defined in this library.")
(license license:bsd-3)))
+
+(define-public ocaml-topkg
+ (package
+ (name "ocaml-topkg")
+ (version "0.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/topkg/releases/"
+ "topkg-" version ".tbz"))
+ (sha256
+ (base32
+ "18rrh6fmf708z7dd30amljmcgaypj3kk49jrmrj68r4wnw8004j8"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("opam" ,opam)))
+ (propagated-inputs
+ `(("result" ,ocaml-result)))
+ (arguments
+ `(#:tests? #f
+ #:build-flags '("build")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://erratique.ch/software/topkg")
+ (synopsis "Transitory OCaml software packager")
+ (description "Topkg is a packager for distributing OCaml software. It
+provides an API to describe the files a package installs in a given build
+configuration and to specify information about the package's distribution,
+creation and publication procedures.")
+ (license license:isc)))