summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 11:17:17 +0100
committerDavid Craven <david@craven.ch>2017-01-04 17:41:10 +0100
commita5b5bd1d18f32c29e704acae24c3e1945666afb9 (patch)
tree041b7764dd62dcd36552a841e921adf43d5d3e90 /gnu/packages/ocaml.scm
parent3d598ebd35f4890e5bb1490b1ba9175d5d46fc06 (diff)
gnu: Add ocaml-bisect.
* gnu/packages/ocaml.scm (ocaml-bisect): New variable. * gnu/packages/patches/ocaml-bisect-fix-camlp4-in-another-directory.patch: New file. * gnu/local.mk (dist_patch_DATA): Add patch. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0a362b1f92..a1c7bc7155 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -960,3 +960,45 @@ full_split, cut, rcut, etc..")
;; the only mention of a license in this project is in its `opam' file
;; where it says `mit'.
(license license:expat)))
+
+
+(define-public ocaml-bisect
+ (package
+ (name "ocaml-bisect")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (ocaml-forge-uri "bisect" version 1051))
+ (sha256
+ (base32
+ "0kcg2rh0qlkfpbv3nhcb75n62b04gbrz0zasq15ynln91zd5qrg0"))
+ (patches
+ (search-patches
+ "ocaml-bisect-fix-camlp4-in-another-directory.patch"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("camlp4" ,camlp4)
+ ("libxml2" ,libxml2)
+ ("which" ,which)))
+ (propagated-inputs
+ `(("camlp4" ,camlp4)))
+ (arguments
+ `(#:test-target "tests"
+ #:make-flags
+ (list "all" (string-append "CAMLP4_LIBDIR="
+ (assoc-ref %build-inputs "camlp4")
+ "/lib/ocaml/site-lib/camlp4"))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "./configure" "-prefix"
+ (assoc-ref outputs "out"))))))))
+ (home-page "http://bisect.x9c.fr")
+ (synopsis "Code coverage tool for the OCaml language")
+ (description "Bisect is a code coverage tool for the OCaml language. It is
+a camlp4-based tool that allows to instrument your application before running
+tests. After application execution, it is possible to generate a report in HTML
+format that is the replica of the application source code annotated with code
+coverage information.")
+ (license license:gpl3+)))