summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 11:42:53 +0100
committerDavid Craven <david@craven.ch>2017-01-04 17:41:11 +0100
commiteb1ba731857ba6c65a4ad63211ad46e2358905bb (patch)
tree79bd7d7cee62b30451e4f74037f9c50347c0276e /gnu/packages/ocaml.scm
parent63147e5e1e088a266779f2572f5177ba085e3157 (diff)
gnu: Add ocaml-mtime.
* gnu/packages/ocaml.scm (ocaml-mtime): New variable. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7c57c5abef..8a1453210e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1153,3 +1153,32 @@ declarative manner, without resorting to exceptions. It defines combinators
to operate on the result type available from OCaml 4.03 in the standard
library.")
(license license:isc)))
+
+(define-public ocaml-mtime
+ (package
+ (name "ocaml-mtime")
+ (version "0.8.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/mtime/releases/"
+ "mtime-" version ".tbz"))
+ (sha256
+ (base32
+ "1hfx4ny2dkw6jf3jppz0640dafl5xgn8r2si9kpwzhmibal8qrah"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("opam" ,opam)))
+ (propagated-inputs
+ `(("topkg" ,ocaml-topkg)))
+ (arguments
+ `(#:tests? #f
+ #:build-flags
+ '("native=true" "native-dynlink=true" "jsoo=false")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://erratique.ch/software/mtime")
+ (synopsis "Monotonic wall-clock time for OCaml")
+ (description "Access monotonic wall-clock time. It allows to measure time
+spans without being subject to operating system calendar time adjustments.")
+ (license license:isc)))