summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-31 12:26:43 +0100
committerLudovic Courtès <ludo@gnu.org>2015-10-31 12:26:43 +0100
commitef89cb4263e14887385ef8240b040be052c741c1 (patch)
treead24d8099d2e0f7c28edb525f441f365488b55bc /gnu/packages/ocaml.scm
parenteed588d9976367cac020d20de9a99d4bce0058b3 (diff)
gnu: lablgtk: Build sequentially.
* gnu/packages/ocaml.scm (lablgtk)[arguments]: Add #:parallel-build? #f.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index fc45805958..ee4e7830b6 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -460,6 +460,11 @@ provers.")
("librsvg" ,librsvg)))
(arguments
`(#:tests? #f ; no check target
+
+ ;; Occasionally we would get "Error: Unbound module GtkThread" when
+ ;; compiling 'gtkThInit.ml', with 'make -j'. So build sequentially.
+ #:parallel-build? #f
+
#:phases
(modify-phases %standard-phases
(replace 'install