summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 12:48:37 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-31 21:35:35 +0100
commit3763eea716f48d553aa3c440310ceede5548f3e8 (patch)
tree4a7a91f18e26a57762ce5740ef7af2f69bbafd4f /gnu/packages/ocaml.scm
parentf8a12de1cbd80c4e041c69e325621bd7837a478b (diff)
gnu: Add ocaml-expect.
* gnu/packages/ocaml.scm (ocaml-expect): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ca5c8e33e9..16ec4723fa 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1861,3 +1861,24 @@ hierarchy of modules.")
matching and substitution, similar to the functionality offered by the Perl
language.")
(license license:lgpl2.1+))); with the OCaml link exception
+
+(define-public ocaml-expect
+ (package
+ (name "ocaml-expect")
+ (version "0.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (ocaml-forge-uri name version 1372))
+ (sha256
+ (base32
+ "07xq8w2x2vffc32z7vk6y14jwbfb1cw0m2lm1jzi60hnr1dvg8by"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("ocaml-pcre" ,ocaml-pcre)
+ ("ounit" ,ocaml-ounit)))
+ (propagated-inputs `(("batteries" ,ocaml-batteries)))
+ (home-page "https://forge.ocamlcore.org/projects/ocaml-expect/")
+ (synopsis "Simple implementation of expect")
+ (description "Help building unitary testing of interactive program. You
+can match the question using a regular expression or a timeout.")
+ (license license:lgpl2.1+))) ; with the OCaml static compilation exception