summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 22:59:51 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:53 +0000
commit4d4486a5c2edc0b1c85eb6e9704e8211a05eb440 (patch)
treedc2b3b88f05702e7599c6692a9f53a2b37422486 /gnu/packages/ocaml.scm
parentfa06b3124c5a711c65179574854d3f9f4242948b (diff)
gnu: Add ocaml-macaddr.
* gnu/packages/ocaml.scm (ocaml-macaddr): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 75f112f0ac..7fb32ade5a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3552,6 +3552,35 @@ and command-line tool.")
length of domain names are preserved throughout the module.")
(license license:isc)))
+(define-public ocaml-macaddr
+ (package
+ (name "ocaml-macaddr")
+ (version "5.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/ocaml-ipaddr/")
+ (commit (string-append "v" version))))
+ (file-name name)
+ (sha256
+ (base32
+ "1zgwx0ms3l4k4dzwnkrwq4zzqjrddjsvqn66mbd0rm6aq1ib019d"))))
+ (build-system dune-build-system)
+ (arguments '(#:package "macaddr"))
+ (propagated-inputs (list ocaml-cstruct ocaml-domain-name))
+ (native-inputs (list ocaml-ounit2 ocaml-ppx-sexp-conv))
+ (home-page "https://github.com/mirage/ocaml-ipaddr")
+ (synopsis "OCaml library for manipulation of MAC address representations")
+ (description
+ "Features:
+@itemize
+@item MAC-48 (Ethernet) address support
+@item @code{Macaddr} is a @code{Map.OrderedType}
+@item All types have sexplib serializers/deserializers optionally via the
+@code{Macaddr_sexp} library
+@end itemize")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")