summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 10:57:46 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:19 +0100
commit6446f0dfc3c4c37c72781f079ae415378f668d52 (patch)
tree84e0b6d84bc768a48dce47a1496beaaa42b7e36c /gnu/packages/ocaml.scm
parent76968f549d4828cc8e6425b0e0ff8568c9803fe3 (diff)
gnu: Remove ocaml4.07-ppx-fail.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-fail): Remove variable. (ocaml-ppx-fail)[properties]: Remove variant. Change-Id: Iec707f415906d109a2eb2076477c2bfecc27bcc8
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 1 insertions, 20 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f8bdff934e..136ab4151a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7381,32 +7381,13 @@ match expressions, and if expressions.")
(base32 "012p9gv7w4sk3b4x0sdmqrmr2856w8xc424waxb6vrybid7qjs95"))))
(build-system dune-build-system)
(propagated-inputs (list ocaml-base ocaml-ppx-here ocaml-ppxlib))
- (properties `((upstream-name . "ppx_fail")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-fail))))
+ (properties `((upstream-name . "ppx_fail")))
(home-page "https://github.com/janestreet/ppx_fail")
(synopsis "Add location to calls to failwiths")
(description "Syntax extension that makes [failwiths] always include a
position.")
(license license:expat)))
-(define-public ocaml4.07-ppx-fail
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-fail)
- (version "0.11.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
- (version-major+minor version)
- "/files/ppx_fail-v" version ".tar.gz"))
- (sha256
- (base32
- "07plqsvljiwvngggfypwq55g46s5my55y45mvlmalrxyppzr03s8"))))
- (propagated-inputs
- (list ocaml-base ocaml-ppx-here ocaml-migrate-parsetree ocaml-ppxlib))
- (properties '())
- (license license:asl2.0))))
-
(define-public ocaml-ppx-cold
(package
(name "ocaml-ppx-cold")