summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:23 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:58 +0000
commit9c6809a6c41a5a3dd20f03d84b51ae13dbf08fe0 (patch)
tree59bdac5c8ed481360a895e6de56e28ce314ac0d4 /gnu/packages/ocaml.scm
parent3b2ca07ed616527f5a6faf2db0845d5f94385cf6 (diff)
gnu: Add ocaml-xenstore.
* gnu/packages/ocaml.scm (ocaml-xenstore): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3492db3778..8ea2827ae2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3055,6 +3055,35 @@ devices.")
ocaml-shared-memory-ring)
(append ocaml-shared-memory-ring)))))
+(define-public ocaml-xenstore
+ (package
+ (name "ocaml-xenstore")
+ (version "2.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/ocaml-xenstore")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1acld5gxmvnhl5iyyy5ancpm7fv9d6ns1x32krcmb62p2czd00ky"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-cstruct ocaml-ppx-cstruct ocaml-lwt))
+ (native-inputs (list ocaml-ounit2))
+ (home-page "https://github.com/mirage/ocaml-xenstore")
+ (synopsis "Xenstore protocol in pure OCaml")
+ (description "Repository contents:
+@itemize
+@item client library, a merge of the Mirage and XCP ones
+@item server library
+@item server instance which runs under Unix with libxc
+@item server instance which runs on mirage.
+@end itemize
+The client and the server libraries have sets of unit-tests.")
+ ;; Has a linking exception, see LICENSE.md.
+ (license license:lgpl2.1)))
+
(define-public ocaml-luv
(package
(name "ocaml-luv")