summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 22:59:54 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:54 +0000
commit9ca7804aafe3a8560a492c561969e8dd39630ed5 (patch)
tree992637e11842b8b4127b5490d1ac1f8f1ac1b23f /gnu/packages/ocaml.scm
parent2dbf7055a5c83adbde5d9fe0b822316bea360cf5 (diff)
gnu: Add ocaml-pecu.
* gnu/packages/ocaml.scm (ocaml-pecu): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d9b0d74c80..17230b5023 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3627,6 +3627,27 @@ length of domain names are preserved throughout the module.")
"IP address types with serialization, supporting a wide range of RFCs.")
(license license:isc)))
+(define-public ocaml-pecu
+ (package
+ (name "ocaml-pecu")
+ (version "0.6")
+ (source (origin
+ (method url-fetch)
+ (uri
+ "https://github.com/mirage/pecu/releases/download/v0.6/pecu-v0.6.tbz")
+ (sha256
+ (base32
+ "1iz5jj9lyl1pah8dfni4wv0qml0ir5zknv4zhw7v50sc8kdbglm9"))))
+ (build-system dune-build-system)
+ (native-inputs (list ocaml-fmt ocaml-alcotest ocaml-crowbar ocaml-astring))
+ (home-page "https://github.com/mirage/pecu")
+ (synopsis "Encoder/Decoder of Quoted-Printable (RFC2045 & RFC2047)")
+ (description
+ "This package provides a non-blocking encoder/decoder of Quoted-Printable
+according to RFC2045 and RFC2047 (about encoded-word). Useful to translate
+contents of emails.")
+ (license license:expat)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")