summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:10 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:56 +0000
commitbd15c8fc3a4f0d3601f229d686ac8d75068b2725 (patch)
tree577b04a81c119f1e16ab1dd7560d55451a319796 /gnu/packages/ocaml.scm
parent34958ee1b6cc4a829320c286a3c85d978b69d466 (diff)
gnu: Add ocaml-sexp-pretty.
* gnu/packages/ocaml.scm (ocaml-sexp-pretty): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 83954cfd86..82cada5a46 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6148,6 +6148,29 @@ functionality for parsing and pretty-printing s-expressions.")
"0ksx62zsxhz8xmdrsn41n2hbc2qbyh3bxxc6946xisvgwh42h3q3"))
(properties '()))))
+(define-public ocaml-sexp-pretty
+ (package
+ (name "ocaml-sexp-pretty")
+ (version "0.15.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/sexp_pretty")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08z9jpvgag5f029ns0a06lcdymg00vwi232xsy1rdv82zvc0x4ah"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-base ocaml-ppx-base ocaml-sexplib ocaml-re))
+ (properties `((upstream-name . "sexp_pretty")))
+ (home-page "https://github.com/janestreet/sexp_pretty")
+ (synopsis "S-expression pretty-printer")
+ (description
+ "Library for pretty-printing s-expressions, using better indentation
+rules than the default pretty printer in Sexplib.")
+ (license license:expat)))
+
(define-public ocaml-base
(package
(name "ocaml-base")