summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-03-18 08:59:01 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-05-10 22:13:54 +0200
commit1345231cc21725e9866edb1b4c2366a038d4b5f3 (patch)
treeb01a770297c8556075550c15453ce4f0a058c83a /gnu/packages/ocaml.scm
parentc6cfec42b089ee7d5663b2193eea33d3de49dad2 (diff)
gnu: Add ocaml4.01-bisect.
* gnu/packages/ocaml.scm (ocaml4.01-bisect): New variable. (ocaml-bisect)[properties]: New field.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c7c473a4cc..b3fee16627 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -59,7 +59,8 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix svn-download)
- #:use-module (guix utils))
+ #:use-module (guix utils)
+ #:use-module (srfi srfi-1))
;; A shortcut for files from ocaml forge. Downloaded files are computed from
;; their number, not their name.
@@ -1126,8 +1127,22 @@ a camlp4-based tool that allows to instrument your application before running
tests. After application execution, it is possible to generate a report in HTML
format that is the replica of the application source code annotated with code
coverage information.")
+ (properties `((ocaml4.01-variant . ,(delay ocaml4.01-bisect))))
(license license:gpl3+)))
+(define-public ocaml4.01-bisect
+ (let ((base (package-with-ocaml4.01 (strip-ocaml4.01-variant ocaml-bisect))))
+ (package
+ (inherit base)
+ (arguments
+ `(#:ocaml ,ocaml-4.01
+ ;; Camlp4 is included with OCaml 4.01, so do not include it as a
+ ;; separate input.
+ ,@(strip-keyword-arguments '(#:make-flags) (package-arguments base))))
+ (native-inputs `(,@(alist-delete "camlp4" (package-native-inputs base))))
+ (propagated-inputs
+ `(,@(alist-delete "camlp4" (package-propagated-inputs base)))))))
+
(define-public ocaml-bitstring
(package
(name "ocaml-bitstring")