summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-28 15:24:58 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-06-06 21:09:54 +0200
commitd7f6d048b116204f849361ef97ca5502c55fa92b (patch)
treec1523f970ef73b3c4e195d46f3688e3fc4ca6d56 /gnu/packages/ocaml.scm
parent7f1620df1441d976d737785310fcd9a02c6b5bce (diff)
gnu: Add ocaml-async-extra.
* gnu/packages/ocaml.scm (ocaml-async-extra): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a40ebea545..aa28320440 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3022,3 +3022,26 @@ standard library that was developed by Jane Street.")
(synopsis "Asynchronous execution library for Unix")
(description "Async_unix is an asynchronous execution library for Unix.")
(license license:asl2.0)))
+
+(define-public ocaml-async-extra
+ (package
+ (name "ocaml-async-extra")
+ (version "113.33.03")
+ (source (janestreet-origin "async_extra" version
+ "1si8jgiq5xh5sl9f2b7f9p17p7zx5h1pg557x2cxywi2x7pxqg4f"))
+ (native-inputs
+ `(("oasis" ,ocaml-oasis)
+ ("js-build-tools" ,ocaml-js-build-tools)
+ ("ppx-jane" ,ocaml-ppx-jane)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("async-rpc-kernel" ,ocaml-async-rpc-kernel)
+ ("async-unix" ,ocaml-async-unix)
+ ("core" ,ocaml-core)))
+ (build-system ocaml-build-system)
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/async_extra")
+ (synopsis "Extra functionnalities for the async library")
+ (description "Async_extra provides additional functionnalities for the
+async library.")
+ (license license:asl2.0)))