summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:04 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:55 +0000
commita9a8d626b1e6b1a055b63932be432cc8d66792c5 (patch)
treedc2d459b659fb2ce025ca2a989409fc47396d453 /gnu/packages/ocaml.scm
parent74560bf3c3b1f373f2d10f71042beb97680f34f9 (diff)
gnu: Add ocaml-ppx-cstruct.
* gnu/packages/ocaml.scm (ocaml-ppx-cstruct): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9069b320e9..7a9e8d4f89 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4462,6 +4462,22 @@ writing to these structures, and they are accessed via the Bigarray module.")
(define ocaml-cstruct-unix ocaml-cstruct)
(define ocaml-cstruct-sexp ocaml-cstruct)
+(define-public ocaml-ppx-cstruct
+ (package
+ (inherit ocaml-cstruct)
+ (name "ocaml-ppx-cstruct")
+ (properties `((upstream-name . "ppx_cstruct")))
+ (arguments
+ '(#:package "ppx_cstruct"
+ ;; TODO doesn't find test deps for some reason?
+ ;; I have no clue why.
+ #:tests? #f))
+ (propagated-inputs (modify-inputs (package-propagated-inputs ocaml-cstruct)
+ (append ocaml-cstruct ocaml-ppxlib ocaml-sexplib)))
+ (native-inputs (modify-inputs (package-propagated-inputs ocaml-cstruct)
+ (append ocaml-cstruct-sexp ocaml-findlib
+ ocaml-ppx-sexp-conv)))))
+
(define-public ocaml-hex
(package
(name "ocaml-hex")