summaryrefslogtreecommitdiff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-14 21:22:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-14 21:52:34 +0100
commit597685054b2b95cbf78e9dd9b32de5d44c57c2cd (patch)
treeb8791533b1c283c86c94303170b72a9d840121b4 /gnu/packages/openldap.scm
parentfa23fb86f7741570d194bba1f227016d9aa25881 (diff)
gnu: 389-ds-base: Update to 2.2.2.
* gnu/packages/openldap.scm (389-ds-base): Update to 2.2.2. [inputs]: Add json-c and lmdb.
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index b3b22d1709..ec5cbf43c6 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cyrus-sasl)
+ #:use-module (gnu packages databases)
#:use-module (gnu packages dbm)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gettext)
@@ -245,7 +246,9 @@ servers from Python programs.")
(define-public 389-ds-base
(package
(name "389-ds-base")
- (version "1.4.5.0")
+ ;; More recent versions require rust. That's not bad, but it's a
+ ;; challenge to integrate three build systems.
+ (version "2.2.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -254,7 +257,7 @@ servers from Python programs.")
(file-name (git-file-name name version))
(sha256
(base32
- "1s627w4kwrbszrkm6k6v32gx7jd27h4yqvs81kjkakiaq2lh1s1z"))))
+ "1sdvfbjfg0091f47562gw3gdc2vgvvhyhdi21lrpwnw9lqc8xdxk"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((srfi srfi-1)
@@ -355,16 +358,18 @@ servers from Python programs.")
httpd
icu4c
iproute
+ json-c
libevent
libselinux
linux-pam
+ lmdb
mit-krb5
net-snmp
nspr
nss
- (list nss "bin") ; for certutil
+ (list nss "bin") ;for certutil
openldap
- openssl ; #included by net-snmp
+ openssl ;#included by net-snmp
pcre
python
python-pyasn1