summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-20 20:41:29 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:38:57 +0200
commit0b929d2d239a5e32f2c87e6744105dff34c72c4a (patch)
tree14908edf0ad19473c0f6ca22fb22a35ad644ec98 /gnu/packages/openstack.scm
parent122bedf2fd843571f11ad68d33735a2a9b21af8a (diff)
gnu: Add python-keystoneauth1.
* gnu/packages/openstack.scm (python-keystoneauth1): New variable.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index df78526175..4e3e933509 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -725,6 +725,66 @@ functions, such as encoding, exception handling, string manipulation, and time
handling.")
(license asl2.0)))
+(define-public python-keystoneauth1
+ (package
+ (name "python-keystoneauth1")
+ (version "5.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "keystoneauth1" version))
+ (sha256
+ (base32
+ "08s36dqxrxqx37sdl28cr7fx2iwr8wfxaa53hwq2dzcx9h25zfvf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "test-requirements.txt"
+ (("hacking[<>!=].*") "hacking\n")
+ ;; unused, code-quality checks only
+ (("flake8-.*[<>!=]" line) (string-append "# " line))
+ (("pycodestyle[<>!=]" line) (string-append "# " line))
+ (("bandit[<>!=]" line) (string-append "# " line))
+ (("coverage[<>!=]" line) (string-append "# " line))
+ (("reno[<>!=]" line) (string-append "# " line)))))
+ (add-before 'check 'check-setup
+ (lambda _
+ ;; remove code-quality checks
+ (delete-file "keystoneauth1/tests/unit/test_hacking_checks.py")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "stestr" "run")))))))
+ (propagated-inputs (list python-iso8601
+ python-os-service-types
+ python-requests
+ python-six
+ python-stevedore))
+ (native-inputs (list python-betamax
+ python-fixtures
+ python-hacking
+ python-lxml
+ python-oauthlib
+ python-oslo.config
+ python-oslo.utils
+ python-oslotest
+ python-pbr
+ python-pyyaml
+ python-requests-kerberos
+ python-requests-mock
+ python-stestr
+ python-testresources
+ python-testtools))
+ (home-page "https://docs.openstack.org/keystoneauth/latest/")
+ (synopsis "Authentication Library for OpenStack Identity")
+ (description "Keystoneauth provides a standard way to do authentication
+and service requests within the OpenStack ecosystem. It is designed for use
+in conjunction with the existing OpenStack clients and for simplifying the
+process of writing new clients.")
+ (license asl2.0)))
+
(define-public python-keystoneclient
(package
(name "python-keystoneclient")