summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-08-16 16:31:24 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-01 23:11:16 +0200
commit7c4810a1e543a66bc7aa53f971e70bf1f9d41b08 (patch)
tree9092649c00ba39fd962c3a1be0be1884f114d819 /gnu/packages/openstack.scm
parent7e7b27d9060420a5dad8e082d71f46c0fea4a7d9 (diff)
gnu: Add python-pbr.
* gnu/packages/openstack.scm: New file. * gnu-system.am: Add it.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm68
1 files changed, 68 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
new file mode 100644
index 0000000000..98619b12f2
--- /dev/null
+++ b/gnu/packages/openstack.scm
@@ -0,0 +1,68 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages openstack)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages version-control)
+ #:use-module (guix build-system python)
+ #:use-module (guix download)
+ #:use-module ((guix licenses)
+ #:select (asl2.0))
+ #:use-module (guix packages))
+
+(define-public python-pbr
+ (package
+ (name "python-pbr")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/p/pbr/pbr-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1l2mls8wnwpkqj6hxsphq7xibbbsf40gg37wc30nj4r600zgqhqm"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;; Most tests seem to use the Internet.
+ (propagated-inputs
+ `(("python-testrepository" ,python-testrepository)
+ ("git" ,git))) ;; pbr actually uses the "git" binary.
+ (inputs
+ `(("python-fixtures" ,python-fixtures)
+ ("python-mimeparse" ,python-mimeparse)
+ ("python-mock" ,python-mock)
+ ("python-setuptools" ,python-setuptools)
+ ("python-six" ,python-six)
+ ("python-sphinx" ,python-sphinx)
+ ("python-testrepository" ,python-testrepository)
+ ("python-testresources" ,python-testresources)
+ ("python-testscenarios" ,python-testscenarios)
+ ("python-testtools" ,python-testtools)
+ ("python-virtualenv" ,python-virtualenv)))
+ (home-page "https://launchpad.net/pbr")
+ (synopsis "Change the default behavior of Python’s setuptools")
+ (description
+ "Python Build Reasonableness (PBR) is a library that injects some useful
+and sensible default behaviors into your setuptools run.")
+ (license asl2.0)))
+
+(define-public python2-pbr
+ (package-with-python2 python-pbr))