summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-20 21:49:40 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:38:58 +0200
commitb08a3554a4577f7fb1557f296aa189bc220e7138 (patch)
treea565bcf3920a247a013d927424709040d6e04260 /gnu/packages/openstack.scm
parent8a4faff132fddc4ff6f26778787cd60e9732d6b3 (diff)
gnu: Add python-tempest.
* gnu/packages/openstack.scm (python-tempest): New variable.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index e84c9ac7bc..5bf5983541 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -346,6 +346,64 @@ classes for implementing common patterns for using dynamically loaded
extensions.")
(license asl2.0)))
+(define-public python-tempest
+ (package
+ (name "python-tempest")
+ (version "31.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "tempest" version))
+ (sha256
+ (base32
+ "1bh250n0cf68jm68jd7pcrgf7zbsv74cq590ar1n002sijfcb80i"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "test-requirements.txt"
+ ;; unused, code-quality checks only
+ (("hacking[<>!=]" line) (string-append "# " line))
+ (("flake8-.*[<>!=]" line) (string-append "# " line))
+ (("pycodestyle[<>!=]" line) (string-append "# " line))
+ (("coverage[<>!=]" line) (string-append "# " line)))))
+ (add-before 'check 'setup-check
+ (lambda _
+ (substitute* "tempest/tests/lib/cli/test_execute.py"
+ (("cli_base.execute\\(\"env\",")
+ (string-append "cli_base.execute('" (which "env") "',")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "stestr" "--test-path" "./tempest/tests" "run")))))))
+ (propagated-inputs (list python-cliff
+ python-cryptography
+ python-debtcollector
+ python-fixtures
+ python-jsonschema
+ python-netaddr
+ python-oslo.concurrency
+ python-oslo.config
+ python-oslo.log
+ python-oslo.serialization
+ python-oslo.utils
+ python-paramiko
+ python-prettytable
+ python-pyyaml
+ python-stevedore
+ python-subunit
+ python-testtools
+ python-urllib3))
+ (native-inputs (list python-oslotest python-pbr python-stestr python-hacking))
+ (home-page "https://docs.openstack.org/tempest/latest/")
+ (synopsis "OpenStack Integration Testing")
+ (description "This is a set of integration tests to be run against a live
+OpenStack cluster. Tempest has batteries of tests for OpenStack API
+validation, scenarios, and other specific tests useful in validating an
+OpenStack deployment.")
+ (license asl2.0)))
+
(define-public python-tempest-lib
(package
(name "python-tempest-lib")