summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-20 10:21:59 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-20 10:29:42 +0100
commit18eb00ecb8777af31279110d2a89e65173d49690 (patch)
tree54779e6772aaf48b1a5e0767aa81fe93ed0bae0a /gnu/packages/package-management.scm
parent86bad0f0a579cc4d072fc9e41eafb08b4acf5d5d (diff)
gnu: guix: Fix cross build of documentation translations.
This fixes building guix-ru.info when building (for the Hurd) guix.ru.texi:3489: @node `??????????????????????' previously defined guix.ru.texi:2535: here is the previous definition as @node make[2]: *** [Makefile:5287: doc/guix.ru.info] Error 1 and building guix-zn-CN.info when building (for the Hurd) guix.zh_CN.texi:651: @node `??????' previously defined guix.zh_CN.texi:522: here is the previous definition as @node make[2]: *** [Makefile:5352: doc/guix.zh_CN.info] Error 1 and building guix-cookbook.ko when building (for the Hurd) guix-cookbook.ko.texi:781: @node `??????' previously defined guix-cookbook.ko.texi:522: here is the previous definition as @node make[2]: *** [Makefile:5549: doc/guix-cookbook.ko.info] Error 1 * gnu/packages/package-management.scm (guix)[native-inputs]: Add libc-utf8-locales-for-target. Change-Id: I561b4da84b31b343e515559feb90d773b1cf440a
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 55e930e510..7c70d5e793 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -460,7 +460,8 @@ $(prefix)/etc/openrc\n")))
;; the 'patch-shebangs' phase, which would otherwise
;; change it to 'GUILE/bin/guile'.
(delete 'patch-shebangs))))
- (native-inputs `(("pkg-config" ,pkg-config)
+ (native-inputs `(("locales" ,(libc-utf8-locales-for-target))
+ ("pkg-config" ,pkg-config)
;; Guile libraries are needed here for
;; cross-compilation.