summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 16:04:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 16:04:29 +0200
commitf3e9dfc5473b5ba7f8d860b2096b56f07d932236 (patch)
treeb2a54ac166bc96ab331911eda6a6b18ba33adb28 /gnu/packages/package-management.scm
parent196977fb6449ad8c4c657f1f9fade8ef90194f6a (diff)
Revert "gnu: nix: Update to 2.16.0."
This reverts commit 554d46882bc4443dcebbba5aac70b016537d0975. Wrong patch revision.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm25
1 files changed, 5 insertions, 20 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 529ed5c666..fbc6c2ca25 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -20,7 +20,7 @@
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
-;;; Copyright © 2022, 2023 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -56,7 +56,6 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages cmake)
#:use-module (gnu packages cpio)
- #:use-module (gnu packages cpp)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
@@ -732,7 +731,7 @@ high-performance computing} clusters.")
(define-public nix
(package
(name "nix")
- (version "2.16.0")
+ (version "2.5.1")
(source
(origin
(method git-fetch)
@@ -741,7 +740,7 @@ high-performance computing} clusters.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0jizpci4zspqpqqy3n780m4wh8dzhfywaiz953xv70c7in810dra"))
+ (base32 "1m8rmv8i6lg83pmalvjlq1fn8mcghn3ngjv3kw1kqsa45ymj5sqq"))
(patches
(search-patches "nix-dont-build-html-doc.diff"))))
(build-system gnu-build-system)
@@ -758,19 +757,7 @@ high-performance computing} clusters.")
(apply invoke "make" "install"
(string-append "sysconfdir=" etc)
(string-append "profiledir=" etc "/profile.d")
- make-flags))))
- (replace 'check
- (lambda args
- ;; Some test expect environment variable NIX_STORE to be
- ;; "/nix/store"
- (let ((original-NIX_STORE (getenv "NIX_STORE")))
- (dynamic-wind
- (lambda ()
- (setenv "NIX_STORE" "/nix/store"))
- (lambda ()
- (apply (assoc-ref %standard-phases 'check) args))
- (lambda ()
- (setenv "NIX_STORE" original-NIX_STORE)))))))))
+ make-flags)))))))
(native-inputs
(list autoconf
autoconf-archive
@@ -780,8 +767,7 @@ high-performance computing} clusters.")
googletest
jq
libtool
- pkg-config
- rapidcheck))
+ pkg-config))
(inputs
(append (list boost
brotli
@@ -793,7 +779,6 @@ high-performance computing} clusters.")
libseccomp
libsodium
lowdown
- nlohmann-json
openssl
sqlite
xz