summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-31 10:21:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-31 10:21:52 -0400
commit47ea688fd27d0ce0c8ea5481f1f94d0ebc3e37eb (patch)
tree031466c89d16597f848102be5a02ec557cae3ad0 /gnu/packages/package-management.scm
parentb8152d668d16faa464d2819af6f8ed4b2637538b (diff)
gnu: conan: Disable more flaky tests.
* gnu/packages/package-management.scm (conan) [arguments]: Run test suite verbosely. Skip the test_toolchain and test_list tests.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 43b6af1d15..29cb481862 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1209,7 +1209,7 @@ tools_locations = {
(setenv "CONFIG_SHELL" (which "sh"))
(setenv "PATH" (string-append (getenv "PATH") ":"
#$output "/bin"))
- (invoke "python" "-m" "pytest"
+ (invoke "python" "-m" "pytest" "-vv"
"-n" (number->string (parallel-job-count))
"-m" "not slow"
;; Disable problematic tests.
@@ -1222,6 +1222,12 @@ tools_locations = {
;; expected by the following test.
"and not pkg_config_path "
"and not compare " ;caused by newer node-semver?
+ ;; This test hard-codes a compiler version.
+ "and not test_toolchain "
+ ;; The 'test_list' tests may fail
+ ;; non-deterministically (see:
+ ;; https://github.com/conan-io/conan/issues/13583).
+ "and not test_list "
;; These tests fail when Autoconf attempt to load a
;; shared library in the same directory (see:
;; https://github.com/conan-io/conan/issues/13577).