summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-26 10:49:07 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-26 10:49:07 +0100
commit9312c6833481ee234713f20c97edf3f1729b941f (patch)
treeb520339152804d895d3a4b236982d6690844cfc7 /gnu/packages/package-management.scm
parenta62c8a80cbb6cbc2f0cf815da674efec1501f1eb (diff)
gnu: guix-build-coordinator: Update to 0-86.f39f160.
* gnu/packages/package-management.scm (guix-build-coordinator): Update to 0-86.f39f160. [arguments]: Update style.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm119
1 files changed, 59 insertions, 60 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 2e4ff51900..b833ce29e7 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1408,8 +1408,8 @@ environments.")
"0k9zkdyyzir3fvlbcfcqy17k28b51i20rpbjwlx2i1mwd2pw9cxc")))))))
(define-public guix-build-coordinator
- (let ((commit "c44d485bba42034804beb47afc23005c4e73ea96")
- (revision "85"))
+ (let ((commit "f39f16000469429745bd8aff3cd4d59b7c489fa1")
+ (revision "86"))
(package
(name "guix-build-coordinator")
(version (git-version "0" revision commit))
@@ -1420,75 +1420,74 @@ environments.")
(commit commit)))
(sha256
(base32
- "1y69yrmmifdp55l5c5b8iiq0llwpggxmq6a4233cdll3bhfxaicl"))
+ "1lmbwbza87xzbvmzw44sgpscmqjfl5kpgfl79n7hzwa1icqqb7mg"))
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
- `(#:modules (((guix build guile-build-system)
+ (list
+ #:modules `(((guix build guile-build-system)
#:select (target-guile-effective-version))
,@%gnu-build-system-modules)
- #:imported-modules ((guix build guile-build-system)
+ #:imported-modules `((guix build guile-build-system)
,@%gnu-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-GUILE_AUTO_COMPILE
- (lambda _
- ;; To avoid warnings relating to 'guild'.
- (setenv "GUILE_AUTO_COMPILE" "0")
- #t))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs target #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (guile (assoc-ref inputs "guile"))
- (version (target-guile-effective-version))
- (scm (string-append out "/share/guile/site/" version))
- (go (string-append out "/lib/guile/" version "/site-ccache")))
- (for-each
- (lambda (file)
- (simple-format (current-error-port) "wrapping: ~A\n" file)
- (let ((guile-inputs (list
- "guile-json"
- "guile-gcrypt"
- "guix"
- "guile-prometheus"
- "guile-lib"
- "guile-lzlib"
- "guile-zlib"
- "guile-sqlite3"
- "guile-gnutls"
- ,@(if (target-hurd?)
- '()
- '("guile-fibers")))))
- (wrap-program file
- `("PATH" ":" prefix
- (,bin
- ;; Support building without sqitch as an input, as it
- ;; can't be cross-compiled yet
- ,@(or (and=> (assoc-ref inputs "sqitch")
- list)
- '())))
- `("GUILE_LOAD_PATH" ":" prefix
- (,scm ,(string-join
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-GUILE_AUTO_COMPILE
+ (lambda _
+ ;; To avoid warnings relating to 'guild'.
+ (setenv "GUILE_AUTO_COMPILE" "0")))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs target #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (guile (assoc-ref inputs "guile"))
+ (version (target-guile-effective-version))
+ (scm (string-append out "/share/guile/site/" version))
+ (go (string-append out "/lib/guile/" version "/site-ccache")))
+ (for-each
+ (lambda (file)
+ (simple-format (current-error-port) "wrapping: ~A\n" file)
+ (let ((guile-inputs (list
+ "guile-json"
+ "guile-gcrypt"
+ "guix"
+ "guile-prometheus"
+ "guile-lib"
+ "guile-lzlib"
+ "guile-zlib"
+ "guile-sqlite3"
+ "guile-gnutls"
+ #$@(if (target-hurd?)
+ '()
+ '("guile-fibers")))))
+ (wrap-program file
+ `("PATH" ":" prefix
+ (,bin
+ ;; Support building without sqitch as an input, as it
+ ;; can't be cross-compiled yet
+ ,@(or (and=> (assoc-ref inputs "sqitch")
+ list)
+ '())))
+ `("GUILE_LOAD_PATH" ":" prefix
+ (,scm ,(string-join
+ (map (lambda (input)
+ (simple-format
+ #f "~A/share/guile/site/~A"
+ (assoc-ref inputs input)
+ version))
+ guile-inputs)
+ ":")))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix
+ (,go ,(string-join
(map (lambda (input)
(simple-format
- #f "~A/share/guile/site/~A"
+ #f "~A/lib/guile/~A/site-ccache"
(assoc-ref inputs input)
version))
guile-inputs)
- ":")))
- `("GUILE_LOAD_COMPILED_PATH" ":" prefix
- (,go ,(string-join
- (map (lambda (input)
- (simple-format
- #f "~A/lib/guile/~A/site-ccache"
- (assoc-ref inputs input)
- version))
- guile-inputs)
- ":"))))))
- (find-files bin)))
- #t))
- (delete 'strip)))) ; As the .go files aren't compatible
+ ":"))))))
+ (find-files bin)))))
+ (delete 'strip)))) ; As the .go files aren't compatible
(native-inputs
(list pkg-config
autoconf