summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2023-01-20 10:57:00 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-20 12:17:54 +0100
commitb60f3941b95dc5351e2336cf694480d099a91233 (patch)
tree853160d74341418c703ad2955b00f390c7519dbe /gnu/packages/package-management.scm
parent43b7a033e3e96b7f3681e2693d63f1fb6b5af26e (diff)
gnu: guix-jupyter: Define 'HOME' prior to 'check' phase.
Fixes <https://issues.guix.gnu.org/57077>. Reported by Andreas Enge <andreas@enge.fr>. * gnu/packages/package-management.scm (guix-jupyter)[arguments]: Add 'define-home' phase.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index d2934ea941..f7a47ece00 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1666,8 +1666,16 @@ This package just includes the agent component.")))
"\",\n\t\t\""))
(("guix-jupyter-kernel.scm")
(string-append out "/share/guile/site/3.0/"
- "guix-jupyter-kernel.scm")))
- #t))))))
+ "guix-jupyter-kernel.scm"))))))
+ (add-before 'check 'define-home
+ (lambda _
+ ;; IPython goes awry when HOME points to a non-existent
+ ;; directory:
+ ;;
+ ;; IPython/paths.py:70: UserWarning: IPython parent '/homeless-shelter' is not a writable location, using a temp directory.
+ ;;
+ ;; This in turn leads to test failures, so define HOME.
+ (setenv "HOME" (getcwd)))))))
(native-inputs
(list autoconf
automake