summaryrefslogtreecommitdiff
path: root/gnu/packages/pantheon.scm
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-05-15 14:24:23 -0500
committerDanny Milosavljevic <dannym@scratchpost.org>2020-05-19 11:48:04 +0200
commit9f59a9b4bc93b3ef6cd3bd1c9eed04c30ba2d2d4 (patch)
treea33793c537d602d12194a408754e13b8bbcb3dd0 /gnu/packages/pantheon.scm
parent9cdb10d52e34f7e8fa3b6238fe268646a4bbb877 (diff)
gnu: Add granite.
* gnu/packages/pantheon.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/pantheon.scm')
-rw-r--r--gnu/packages/pantheon.scm67
1 files changed, 67 insertions, 0 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
new file mode 100644
index 0000000000..8c5c1634ee
--- /dev/null
+++ b/gnu/packages/pantheon.scm
@@ -0,0 +1,67 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages pantheon)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages)
+ #:use-module (guix build-system meson)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) :prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils))
+
+(define-public granite
+ (package
+ (name "granite")
+ (version "5.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/granite.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0acicv3f9gksb352v88lwap8ailjsxdrfknl2xql7blasbjzl2q0"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-icon-cache
+ (lambda _
+ (setenv "DESTDIR" "/")
+ #t)))))
+ (inputs
+ `(("gtk" ,gtk+)))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)
+ ("libgee" ,libgee)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (home-page "https://github.com/elementary/granite")
+ (synopsis "Library that extends GTK with common widgets and utilities")
+ (description "Granite is a companion library for GTK+ and GLib. Among other
+things, it provides complex widgets and convenience functions designed for use
+in apps built for the Pantheon desktop.")
+ (license license:lgpl3+)))