summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:31:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:42:04 +0300
commit64c043e63a4be97f59fd1906c47973a74eedda67 (patch)
tree37b15dfb4830e4f874edca87b521b6e9cdc3c81b /gnu/packages/password-utils.scm
parentb1f763de54dc2b8e240d0f01f7948ce76f67243e (diff)
parent75af73e1b7ac58770122d8831faa3a8158638bb0 (diff)
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm45
1 files changed, 9 insertions, 36 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 86e80e8328..da140b29ad 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 David Dashyan <mail@davie.li>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -952,13 +953,13 @@ between hosts and entries in the password store.")
(native-inputs
(list perl))
(inputs
- `(("gmp" ,gmp)
- ("libpcap" ,libpcap)
- ("nss" ,nss)
- ("openssl" ,openssl)
- ("python" ,python-2) ; For "python" and "python2" shebangs
- ("ruby" ,ruby) ; For genincstats.rb
- ("zlib" ,zlib)))
+ (list gmp
+ libpcap
+ nss
+ openssl
+ python-wrapper
+ ruby ; For genincstats.rb
+ zlib))
(arguments
`(#:configure-flags
(list "--with-systemwide"
@@ -1019,8 +1020,7 @@ between hosts and entries in the password store.")
(find-files "." "(.*\\.chr|.*\\.lst)")
(find-files "." ".*\\.conf")))
(copy-recursively "rules" (string-append datadir "/rules")))
- (copy-recursively "../doc" docdir)
- #t)))
+ (copy-recursively "../doc" docdir))))
(delete 'check) ; Tests need installed .conf files; move after install
(add-after 'install 'check
(lambda args
@@ -1036,33 +1036,6 @@ of the box are Windows LM hashes, plus lots of other hashes and ciphers. This
is the community-enhanced, \"jumbo\" version of John the Ripper.")
(license license:gpl2+))))
-(define-public sala
- (package
- (name "sala")
- (version "1.3")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "sala" version))
- (sha256
- (base32
- "13qgmc3i2a0cqp8jqrfl93lnphfagb32pgfikc1gza2a14asxzi8"))))
- (build-system python-build-system)
- (arguments
- ;; Sala is supposed to work with Python 3.2 or higher,
- ;; but it doesn't work with Python 3.6. Better stick
- ;; to Python 2, which works fine.
- `(#:python ,python-2))
- (propagated-inputs
- (list gnupg pwgen))
- (home-page "http://www.digip.org/sala/")
- (synopsis "Encrypted plaintext password store")
- (description
- "Store passwords and other bits of sensitive plain-text information
-to encrypted files on a directory hierarchy. The information is protected
-by GnuPG's symmetrical encryption.")
- (license license:expat)))
-
(define-public fpm2
(package
(name "fpm2")