summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-10-13 23:10:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:02 +0200
commit4daa160b7bfa4c1999ee7f13162e25d7a5a108dc (patch)
treedd171f45ad7c8fcefb2b6d28b435534cb7080efb /gnu/packages/password-utils.scm
parent638d60c4a22deb7c7cfa66b0707260fb6b742241 (diff)
gnu: Add age.
* gnu/packages/password-utils.scm (age): New variable.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index fb17e426a7..df114aed7e 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -114,6 +114,35 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages xml))
+(define-public age
+ (package
+ (name "age")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FiloSottile/age")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19fz68n262kvg2ssw4r6nik30zk6g6cy7rdi0fm05czwigqrdz1i"))))
+ (build-system go-build-system)
+ (arguments `(#:import-path "filippo.io/age"))
+ (inputs
+ (list go-golang-org-x-sys
+ go-golang-org-x-term
+ go-golang-org-x-crypto
+ go-filippo-io-edwards25519))
+ (home-page "https://filippo.io/age")
+ (synopsis "Secure file encryption tool, format, and Go library")
+ (description
+ "This package implements file encryption according to the
+@{age-encryption.org/v1, https://age-encryption.org/v1} specification.
+It features small explicit keys, no configuration options, and Unix-style
+composability.")
+ (license license:bsd-3)))
+
(define-public pwgen
(package
(name "pwgen")