summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorJakob Kirsch <jakob.kirsch@web.de>2023-08-02 14:37:13 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-08-02 14:40:45 +0200
commit6ccfa48d83b9c513b40835ae0c5896102b4dd915 (patch)
treebd1bc83a056da7df813c9383248b73a0a48a5d57 /gnu/packages/password-utils.scm
parent84ea83e44f1db2d442462e712b71f7c6d1565681 (diff)
gnu: john-the-ripper-jumbo: Fix compilation with GCC 11+.
* gnu/packages/patches/john-the-ripper-jumbo-with-gcc-11.patch: New file. * gnu/local.mk (dist_PATCH_DATA): Register it. * gnu/packages/password-utils.scm (john-the-ripper-jumbo)[source]: Use it. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index f4f172d159..4768b99750 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1179,8 +1179,8 @@ between hosts and entries in the password store.")
(uri (string-append "http://www.openwall.com/john/j/john-"
official-version "-jumbo-" jumbo-version ".tar.xz"))
(sha256
- (base32
- "0fvz3v41hnaiv1ggpxanfykyfjq79cwp9qcqqn63vic357w27lgm"))))
+ (base32 "0fvz3v41hnaiv1ggpxanfykyfjq79cwp9qcqqn63vic357w27lgm"))
+ (patches (search-patches "john-the-ripper-jumbo-with-gcc-11.patch"))))
(build-system gnu-build-system)
(native-inputs
(list perl))