summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/abiword-wmf-version-lookup-fix.patch
diff options
context:
space:
mode:
authorMarek Benc <merkur32@gmail.com>2014-09-09 13:54:38 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-09 13:55:20 +0200
commit698d228001a27017ced5a69abdfe3b977b116705 (patch)
treeb69b9f7ce7e56bafdadfb65142ac00d13d1d372a /gnu/packages/patches/abiword-wmf-version-lookup-fix.patch
parent52910ded6c36580d0d1f2be5a686f7cb1f9623b9 (diff)
gnu: Add AbiWord.
* gnu/packages/patches/abiword-explictly-cast-bools.patch New file. * gnu/packages/patches/abiword-link-plugins-against-backend.patch: New file. * gnu/packages/patches/abiword-no-include-glib-internal-headers.patch: New file. * gnu/packages/patches/abiword-pass-no-undefined-to-linker.patch * gnu/packages/patches/abiword-use-proper-png-api.patch: New file. * gnu/packages/patches/abiword-wmf-version-lookup-fix.patch: New file. * gnu/packages/abiword.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add abiword.scm. (dist_patch_DATA): Add the 6 patches for abiword. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/abiword-wmf-version-lookup-fix.patch')
-rw-r--r--gnu/packages/patches/abiword-wmf-version-lookup-fix.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/abiword-wmf-version-lookup-fix.patch b/gnu/packages/patches/abiword-wmf-version-lookup-fix.patch
new file mode 100644
index 0000000000..f27f32f30b
--- /dev/null
+++ b/gnu/packages/patches/abiword-wmf-version-lookup-fix.patch
@@ -0,0 +1,28 @@
+The way the configure script determines the version of libwmf is by temporarily
+making dots separator characters, but since the file name of the program which
+returns the version contains dots in Guix (the version in the store entry name),
+doing it this way will always fail.
+
+This is a simple guix-specific fix for the problem.
+
+--- a/configure 2010-06-13 23:17:37.000000000 +0200
++++ b/configure 2014-09-08 17:31:52.102371800 +0200
+@@ -21140,13 +21140,11 @@
+ $as_echo "$as_me: WARNING: wmf plugin: program libwmf-config not found in path" >&2;}
+ fi
+ else
+- IFS_old="$IFS"
+- IFS='.'
+- set -- `$libwmfconfig --version`
+- libwmf_major_found="${1}"
+- libwmf_minor_found="${2}"
+- libwmf_micro_found="${3}"
+- IFS="$IFS_old"
++ libwmf_fullver_found=`$libwmfconfig --version`
++ libwmf_major_found=$(echo $libwmf_fullver_found | cut -d . -f 1)
++ libwmf_minor_found=$(echo $libwmf_fullver_found | cut -d . -f 2)
++ libwmf_micro_found=$(echo $libwmf_fullver_found | cut -d . -f 3)
++
+ if test "$libwmf_major_found" -gt "$libwmf_major_req"; then
+ wmf_deps="yes"
+ elif test "$libwmf_major_found" -eq "$libwmf_major_req" &&