summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/bash-completion-directories.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-12 22:08:04 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-12 22:52:18 +0100
commit16629c8adf90db559a32b7a2c5ec8a94be7ef7ba (patch)
tree0a3f6e03d1bf622e372ff6c52ff6d771d779b0aa /gnu/packages/patches/bash-completion-directories.patch
parentcd9bc11273d11765db2c7431191c08d7ac969c7a (diff)
gnu: bash-completion: Search for completion modules in profiles.
* gnu/packages/patches/bash-completion-directories.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/bash.scm (bash-completion)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/bash-completion-directories.patch')
-rw-r--r--gnu/packages/patches/bash-completion-directories.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/bash-completion-directories.patch b/gnu/packages/patches/bash-completion-directories.patch
new file mode 100644
index 0000000000..1a3e2f55c5
--- /dev/null
+++ b/gnu/packages/patches/bash-completion-directories.patch
@@ -0,0 +1,33 @@
+Bash-completion is written with FHS in mind where completion scripts
+all get added to /usr/share/bash-completion/completions and are picked
+up by the dynamic completion loader from there---whether they are
+part of bash-completion or installed by another package.
+
+On Guix systems, we want not only to search within bash-completion's own
+directory, but also in the user's profile and in the system profile.
+This is what this patch does.
+
+--- bash-completion-2.1/bash_completion 2015-03-11 09:45:45.056846446 +0100
++++ bash-completion-2.1/bash_completion 2015-03-11 09:52:43.248159504 +0100
+@@ -1928,9 +1928,20 @@ _completion_loader()
+ local compfile=./completions
+ [[ $BASH_SOURCE == */* ]] && compfile="${BASH_SOURCE%/*}/completions"
+ compfile+="/${1##*/}"
++ local base="${1##*/}"
+
++ # Look for completion files in the user and global profiles and
++ # lastly in 'bash-completion' itself.
++ for file in \
++ "$HOME/.guix-profile/share/bash-completion/completions/$base" \
++ "$HOME/.guix-profile/etc/bash_completion.d/$base" \
++ "/run/current-system/profile/share/bash-completion/completions/$base" \
++ "/run/current-system/profile/etc/bash_completion.d/$base" \
++ "$compfile"
++ do
+ # Avoid trying to source dirs; https://bugzilla.redhat.com/903540
+- [[ -f "$compfile" ]] && . "$compfile" &>/dev/null && return 124
++ [[ -f "$file" ]] && . "$file" &>/dev/null && return 124
++ done
+
+ # Need to define *something*, otherwise there will be no completion at all.
+ complete -F _minimal "$1" && return 124