summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/binutils-mingw-w64-deterministic.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-11 00:10:23 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-11 00:10:23 +0200
commitbdb90df764661c11b37c988ea129c8e7a01b1889 (patch)
treec320b71b136bfcc5e5ec949279a05c8134fb0cca /gnu/packages/patches/binutils-mingw-w64-deterministic.patch
parentb859a1bf7953eb98668cb11b459cde48b0dce991 (diff)
parent8ec9c5fd880be35fe322b0d4dbc69bd2c6c89ef1 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/binutils-mingw-w64-deterministic.patch')
-rw-r--r--gnu/packages/patches/binutils-mingw-w64-deterministic.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/binutils-mingw-w64-deterministic.patch b/gnu/packages/patches/binutils-mingw-w64-deterministic.patch
new file mode 100644
index 0000000000..3e48b87935
--- /dev/null
+++ b/gnu/packages/patches/binutils-mingw-w64-deterministic.patch
@@ -0,0 +1,22 @@
+This following patch was originally found at the debian mingw-w64 team's
+binutils repo located here:
+https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64.git
+
+Invoke the following in the aforementioned repo to see the original patch:
+
+ $ git show da63f6b:debian/patches/reproducible-import-libraries.patch
+
+Description: Make DLL import libraries reproducible
+Author: Benjamin Moody <benjamin.moody@gmail.com>
+Bug-Debian: https://bugs.debian.org/915055
+
+--- a/ld/pe-dll.c
++++ b/ld/pe-dll.c
+@@ -2844,6 +2844,7 @@
+
+ bfd_set_format (outarch, bfd_archive);
+ outarch->has_armap = 1;
++ outarch->flags |= BFD_DETERMINISTIC_OUTPUT;
+
+ /* Work out a reasonable size of things to put onto one line. */
+ ar_head = make_head (outarch);