summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2020-03-24 15:39:06 -0400
committerCarl Dong <contact@carldong.me>2020-04-02 17:59:53 -0400
commit79825bee07fceb781efc40a8c56a85aac13bba5a (patch)
tree6e4426eb273711bf96196e3ada9e776acf501af3 /gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
parent5517750344be05c91bc2979c1a0e2348a9ae902d (diff)
gnu: cross-base: Add mingw-w64 specific binutils patches.
These patches were originally found at the debian mingw-w64 team's binutils repo, and should improve the reproducibility of our mingw-w64 toolchain. * gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch: New file. * gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch: New file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/cross-base.scm (cross-binutils): Apply relevant patches if target is mingw-w64. (package-with-extra-patches): New procedure.
Diffstat (limited to 'gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch')
-rwxr-xr-xgnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch b/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
new file mode 100755
index 0000000000..3e48b87935
--- /dev/null
+++ b/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
@@ -0,0 +1,22 @@
+This following patch was originally found at the debian mingw-w64 team's
+binutils repo located here:
+https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64.git
+
+Invoke the following in the aforementioned repo to see the original patch:
+
+ $ git show da63f6b:debian/patches/reproducible-import-libraries.patch
+
+Description: Make DLL import libraries reproducible
+Author: Benjamin Moody <benjamin.moody@gmail.com>
+Bug-Debian: https://bugs.debian.org/915055
+
+--- a/ld/pe-dll.c
++++ b/ld/pe-dll.c
+@@ -2844,6 +2844,7 @@
+
+ bfd_set_format (outarch, bfd_archive);
+ outarch->has_armap = 1;
++ outarch->flags |= BFD_DETERMINISTIC_OUTPUT;
+
+ /* Work out a reasonable size of things to put onto one line. */
+ ar_head = make_head (outarch);