summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/blast+-fix-makefile.patch
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-07-03 23:00:14 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-07-08 12:05:59 +1000
commit4732e6ee84fea4e58b8a62cad054b10966f4f6e6 (patch)
tree6e808b2b7abb09b4d954d045fbe916952006786a /gnu/packages/patches/blast+-fix-makefile.patch
parentf2fa86cc82b5941bde63b666337eea59aa609e55 (diff)
gnu: blast+: Update to 2.6.0.
* gnu/packages/bioinformatics.scm (blast+): Update to 2.6.0. [origin]: Remove bundled pcre. Add patch. [arguments]: Replace paths in run_with_lock.c. Configure with pcre. [inputs]: Add pcre, perl, python. * gnu/packages/patches/blast+-fix-makefile.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/blast+-fix-makefile.patch')
-rw-r--r--gnu/packages/patches/blast+-fix-makefile.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/blast+-fix-makefile.patch b/gnu/packages/patches/blast+-fix-makefile.patch
new file mode 100644
index 0000000000..bfa46a7e51
--- /dev/null
+++ b/gnu/packages/patches/blast+-fix-makefile.patch
@@ -0,0 +1,15 @@
+Without this patch, the 'make install' attempts to 'install' a directory, which causes an error.
+
+diff --git a/c++/src/build-system/Makefile.in.top b/c++/src/build-system/Makefile.in.top
+index 1abe44f..d6000b3 100644
+--- a/c++/src/build-system/Makefile.in.top
++++ b/c++/src/build-system/Makefile.in.top
+@@ -51,7 +51,7 @@ install-toolkit:
+ done
+ cd $(includedir0) && find * -name CVS -prune -o -print |\
+ cpio -pd $(pincludedir)
+- $(INSTALL) -m 644 $(incdir)/* $(pincludedir)
++ cp -R $(incdir)/* $(pincludedir)
+ ## set up appropriate build and status directories somewhere under $(libdir)?
+
+ install-gbench: