summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/clang-libc-search-path.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-19 17:18:03 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-19 17:23:48 +0200
commitfd6ae1b9836ffe74105f26930d101d1297849740 (patch)
tree16c1a0ba29c5a5883b88f186148ecefc3f91c7af /gnu/packages/patches/clang-libc-search-path.patch
parentef11ac87013a67f2c4454adf7d477a5c602a14b3 (diff)
gnu: clang: Allow 'clang' to link executables.
* gnu/packages/patches/clang-libc-search-path.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/llvm.scm (clang-from-llvm)[source]: Use it. [inputs]: Add "gcc-lib". [arguments]. Add -DGCC_INSTALL_PREFIX and -DC_INCLUDE_DIRS to #:configure-flags. Add #:phases argument.
Diffstat (limited to 'gnu/packages/patches/clang-libc-search-path.patch')
-rw-r--r--gnu/packages/patches/clang-libc-search-path.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/clang-libc-search-path.patch b/gnu/packages/patches/clang-libc-search-path.patch
new file mode 100644
index 0000000000..327336ac09
--- /dev/null
+++ b/gnu/packages/patches/clang-libc-search-path.patch
@@ -0,0 +1,19 @@
+Clang attempts to guess file names based on the OS and distro (yes!),
+but unfortunately, that doesn't work for us.
+
+This patch makes it easy to insert libc's $libdir so that Clang passes the
+correct absolute file name of crt1.o etc. to 'ld'.
+
+--- cfe-3.6.0.src/lib/Driver/ToolChains.cpp 2015-02-18 22:03:07.000000000 +0100
++++ cfe-3.6.0.src/lib/Driver/ToolChains.cpp 2015-06-19 16:37:20.459701044 +0200
+@@ -3085,6 +3085,10 @@ Linux::Linux(const Driver &D, const llvm
+
+ addPathIfExists(SysRoot + "/lib", Paths);
+ addPathIfExists(SysRoot + "/usr/lib", Paths);
++
++ // Add libc's lib/ directory to the search path, so that crt1.o, crti.o,
++ // and friends can be found.
++ addPathIfExists("@GLIBC_LIBDIR@", Paths);
+ }
+
+ bool Linux::HasNativeLLVMSupport() const {