summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-07-08 15:58:49 +0000
committerLudovic Courtès <ludo@gnu.org>2022-07-12 01:17:45 +0200
commit3485984a090edd5b1721a69a389a2e44077354e7 (patch)
tree73bd1c1545d574b6926cfef9d6b0562f00c2d980 /gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch
parente5e352ae2a92d6653dbb906eeeeb63c072b7184c (diff)
gnu: llvm-3.7, llvm-3.8: Fix build with gcc.
* gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch, gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch: New files. * gnu/packages/llvm.scm (clang-runtime-3.7, llvm-3.7, llvm-3.8): Use patches. * gnu/local.mk: Register patches. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch')
-rw-r--r--gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch b/gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch
new file mode 100644
index 0000000000..042f0e025a
--- /dev/null
+++ b/gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch
@@ -0,0 +1,16 @@
+Patch based on changes from
+https://github.com/llvm/llvm-project/commit/c1fde4fa943fd03a3d40bc5d32b9e0045fd29208
+
+diff --git a/lib/sanitizer_common/scripts/gen_dynamic_list.py b/lib/sanitizer_common/scripts/gen_dynamic_list.py
+index 5ea2ca1..d7bc287 100755
+--- a/lib/sanitizer_common/scripts/gen_dynamic_list.py
++++ b/lib/sanitizer_common/scripts/gen_dynamic_list.py
+@@ -100,7 +100,7 @@ def main(argv):
+ print('global:')
+ result.sort()
+ for f in result:
+- print(' ' + f.encode('utf-8') + ';')
++ print(u' %s;' % f)
+ if args.version_list:
+ print('local:')
+ print(' *;')