summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/curl-bounds-check.patch
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-10-04 10:28:42 -0400
committerKei Kebreau <kkebreau@posteo.net>2017-10-04 19:37:55 -0400
commit46cf31868c1b12eec50bc9b8dda64604dd81f986 (patch)
treee66586c0e463af2c2dcc94f427bf29d3fc9755fc /gnu/packages/patches/curl-bounds-check.patch
parent488d380c82c0b4aac631e15099eb8d40551d49e0 (diff)
gnu: curl: Update replacement to 7.56.0 [security fixes].
Fixes CVE-2017-1000254. See <https://curl.haxx.se/docs/adv_20171004.html> for details. * gnu/packages/curl.scm (curl)[replacement]: Update to 7.56.0. (curl-7.55.0): Rename to ... (curl-7.56.0): ... this. [arguments]: Remove 'fix-Makefile' phase. [source]: Remove patch. * gnu/packages/patches/curl-bounds-check.patch: Delete it. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches/curl-bounds-check.patch')
-rw-r--r--gnu/packages/patches/curl-bounds-check.patch19
1 files changed, 0 insertions, 19 deletions
diff --git a/gnu/packages/patches/curl-bounds-check.patch b/gnu/packages/patches/curl-bounds-check.patch
deleted file mode 100644
index 4b8ff65304..0000000000
--- a/gnu/packages/patches/curl-bounds-check.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Fix test failure on some 32-bit platforms.
-
-Patch copied from upstream source repository:
-
-https://github.com/curl/curl/commit/45a560390c4356bcb81d933bbbb229c8ea2acb63
-
-diff --git a/src/tool_paramhlp.c b/src/tool_paramhlp.c
-index b9dedc989e..85c5e79a7e 100644
---- a/src/tool_paramhlp.c
-+++ b/src/tool_paramhlp.c
-@@ -218,7 +218,7 @@ static ParameterError str2double(double *val, const char *str, long max)
- num = strtod(str, &endptr);
- if(errno == ERANGE)
- return PARAM_NUMBER_TOO_LARGE;
-- if((long)num > max) {
-+ if(num > max) {
- /* too large */
- return PARAM_NUMBER_TOO_LARGE;
- }