summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/curl-bounds-check.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-13 16:46:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-13 16:46:41 +0200
commitd5daf6fbe06ad7a5e0bfc8100584f1ac33a9f2a9 (patch)
treee4b30f8ad8365a0748c4020d3cc40d97a33dc7ff /gnu/packages/patches/curl-bounds-check.patch
parent97660820450e5d2d8524952cce8a444eaf00c428 (diff)
gnu: curl: Fix i686 test failure.
* gnu/packages/patches/curl-bounds-check.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/curl.scm (curl-7.55.0)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/curl-bounds-check.patch')
-rw-r--r--gnu/packages/patches/curl-bounds-check.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/curl-bounds-check.patch b/gnu/packages/patches/curl-bounds-check.patch
new file mode 100644
index 0000000000..4b8ff65304
--- /dev/null
+++ b/gnu/packages/patches/curl-bounds-check.patch
@@ -0,0 +1,19 @@
+Fix test failure on some 32-bit platforms.
+
+Patch copied from upstream source repository:
+
+https://github.com/curl/curl/commit/45a560390c4356bcb81d933bbbb229c8ea2acb63
+
+diff --git a/src/tool_paramhlp.c b/src/tool_paramhlp.c
+index b9dedc989e..85c5e79a7e 100644
+--- a/src/tool_paramhlp.c
++++ b/src/tool_paramhlp.c
+@@ -218,7 +218,7 @@ static ParameterError str2double(double *val, const char *str, long max)
+ num = strtod(str, &endptr);
+ if(errno == ERANGE)
+ return PARAM_NUMBER_TOO_LARGE;
+- if((long)num > max) {
++ if(num > max) {
+ /* too large */
+ return PARAM_NUMBER_TOO_LARGE;
+ }