summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/curlftpfs-fix-memory-leak.patch
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commit8244aea1829eec8aa68289d9832e3b77a26fbed9 (patch)
tree3fcf9b2f8aa149c557c2079b6f5fc9fa6ecfee1f /gnu/packages/patches/curlftpfs-fix-memory-leak.patch
parentaffea88cf5e44b969cf599d310323e5855dadc13 (diff)
gnu: curlftpfs: Add patches to fix bugs.
* gnu/packages/file-systems.scm (curlftpfs)[source]: Add patches. * gnu/packages/patches/curlftpfs-fix-error-closing-file.patch, gnu/packages/patches/curlftpfs-fix-file-names.patch, gnu/packages/patches/curlftpfs-fix-memory-leak.patch, gnu/packages/patches/curlftpfs-fix-no_verify_hostname.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/patches/curlftpfs-fix-memory-leak.patch')
-rw-r--r--gnu/packages/patches/curlftpfs-fix-memory-leak.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/curlftpfs-fix-memory-leak.patch b/gnu/packages/patches/curlftpfs-fix-memory-leak.patch
new file mode 100644
index 0000000000..eea801957e
--- /dev/null
+++ b/gnu/packages/patches/curlftpfs-fix-memory-leak.patch
@@ -0,0 +1,23 @@
+From 2d01202eee44d8bad5bb982e72829b4a98d58bcd Mon Sep 17 00:00:00 2001
+From: Joseph Lansdowne <j49137@gmail.com>
+Date: Thu, 4 Apr 2019 20:37:06 +0100
+Subject: [PATCH] fix memory leak
+
+---
+ ChangeLog | 1 +
+ ftpfs.c | 2 ++
+ 2 files changed, 3 insertions(+)
+
+diff --git a/ftpfs.c b/ftpfs.c
+index 34f8c38..020e559 100644
+--- a/ftpfs.c
++++ b/ftpfs.c
+@@ -607,6 +607,8 @@ static int finish_write_thread(struct ftpfs_file *fh)
+
+
+ static void free_ftpfs_file(struct ftpfs_file *fh) {
++ buf_free(&fh->buf);
++ buf_free(&fh->stream_buf);
+ if (fh->write_conn)
+ curl_easy_cleanup(fh->write_conn);
+ g_free(fh->full_path);