summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/dante-non-darwin.patch
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-12-07 12:28:29 +0900
committerLudovic Courtès <ludo@gnu.org>2023-12-22 17:47:16 +0100
commit4a1b3830a8ff6b05ad9a2b27c8a2cdbd00a45787 (patch)
tree8b525930f1c165d29eb187227f7bc88e2683318f /gnu/packages/patches/dante-non-darwin.patch
parent211c66d49e720eb32c866234ec450d51f322584c (diff)
gnu: dante: Enable preloading support.
Fixes <https://issues.guix.gnu.org/63250>. Dante uses dlopen which doesn't work with libc.so but libc.so.6. This fixes socksify, which is patched to skip invoking uname needlessly. * gnu/packages/networking.scm (dante): Enable preloading support. * gnu/packages/patches/dante-non-darwin.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. References: https://github.com/NixOS/nixpkgs/pull/68418#discussion_r343625853 Change-Id: I03a5b6b6e11cf6a0453a4968ff00c6dd627249a8 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/dante-non-darwin.patch')
-rw-r--r--gnu/packages/patches/dante-non-darwin.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/dante-non-darwin.patch b/gnu/packages/patches/dante-non-darwin.patch
new file mode 100644
index 0000000000..0ecb705c78
--- /dev/null
+++ b/gnu/packages/patches/dante-non-darwin.patch
@@ -0,0 +1,15 @@
+Disable runtime check for Darwin so we don't have to substitute uname.
+--- a/bin/socksify.in
++++ b/bin/socksify.in
+@@ -65,11 +65,6 @@
+ unset FULLPATH
+ fi
+
+-#use "FLAT_NAMESPACE" on Darwin in attempt to match LD_PRELOAD behavior
+-if test x`uname` = xDarwin; then
+- export DYLD_FORCE_FLAT_NAMESPACE=t
+-fi
+-
+ #dlib/Makefile.am libtool flags should produce a predictable library name
+ #(ending in SOLIB_POSTFIX).
+ LIBRARY="${SOCKS_LIBRARY:-${FULLPATH}libdsocks.@SOLIB_POSTFIX@}"