summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/docker-adjust-tests-for-changes-in-go.patch
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-01-03 02:34:33 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-02-10 17:00:24 +0100
commit8c7eb58453870f380a077c7cfd8dafa97bb8e13f (patch)
tree0926d913920d76c89ca5fdf9d13d7a49dc9ae4fe /gnu/packages/patches/docker-adjust-tests-for-changes-in-go.patch
parentd78178fa489c73713d555d2a70dd2bd5e3e5553d (diff)
gnu: docker: Update to 19.03.5.
* gnu/packages/docker.scm (docker-cli): Update to 19.03.5. (docker)[source]: Remove patches. [arguments]<#:phases>[patch-paths]: Modify. [native-inputs]: Add gotestsum. * gnu/packages/patches/docker-adjust-tests-for-changes-in-go.patch: Delete file. * gnu/packages/patches/docker-engine-test-noinstall.patch: Delete file. * gnu/packages/patches/docker-use-fewer-modprobes.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/docker-adjust-tests-for-changes-in-go.patch')
-rw-r--r--gnu/packages/patches/docker-adjust-tests-for-changes-in-go.patch67
1 files changed, 0 insertions, 67 deletions
diff --git a/gnu/packages/patches/docker-adjust-tests-for-changes-in-go.patch b/gnu/packages/patches/docker-adjust-tests-for-changes-in-go.patch
deleted file mode 100644
index 82d92cd4de..0000000000
--- a/gnu/packages/patches/docker-adjust-tests-for-changes-in-go.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 4983ef7c1693ad6dfbe4e3809b12541241d7ff56 Mon Sep 17 00:00:00 2001
-From: Sebastiaan van Stijn <github@gone.nl>
-Date: Wed, 14 Aug 2019 02:51:08 +0200
-Subject: [PATCH] Adjust tests for changes in Go 1.12.8 / 1.11.13
-
-```
-00:38:11 === Failed
-00:38:11 === FAIL: opts TestParseDockerDaemonHost (0.00s)
-00:38:11 hosts_test.go:87: tcp tcp:a.b.c.d address expected error "Invalid bind address format: tcp:a.b.c.d" return, got "parse tcp://tcp:a.b.c.d: invalid port \":a.b.c.d\" after host" and addr
-00:38:11 hosts_test.go:87: tcp tcp:a.b.c.d/path address expected error "Invalid bind address format: tcp:a.b.c.d/path" return, got "parse tcp://tcp:a.b.c.d/path: invalid port \":a.b.c.d\" after host" and addr
-00:38:11
-00:38:11 === FAIL: opts TestParseTCP (0.00s)
-00:38:11 hosts_test.go:129: tcp tcp:a.b.c.d address expected error Invalid bind address format: tcp:a.b.c.d return, got parse tcp://tcp:a.b.c.d: invalid port ":a.b.c.d" after host and addr
-00:38:11 hosts_test.go:129: tcp tcp:a.b.c.d/path address expected error Invalid bind address format: tcp:a.b.c.d/path return, got parse tcp://tcp:a.b.c.d/path: invalid port ":a.b.c.d" after host and addr
-```
-
-Signed-off-by: Sebastiaan van Stijn <github@gone.nl>
-Upstream-commit: 683766613a8c1dca8f95b19ddb7e083bb3aef266
-Component: engine
----
- opts/hosts_test.go | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/opts/hosts_test.go b/opts/hosts_test.go
-index 8c54ec0f4b..7a0a943adf 100644
---- a/opts/hosts_test.go
-+++ b/opts/hosts_test.go
-@@ -53,8 +53,8 @@ func TestParseHost(t *testing.T) {
- func TestParseDockerDaemonHost(t *testing.T) {
- invalids := map[string]string{
-
-- "tcp:a.b.c.d": "Invalid bind address format: tcp:a.b.c.d",
-- "tcp:a.b.c.d/path": "Invalid bind address format: tcp:a.b.c.d/path",
-+ "tcp:a.b.c.d": "",
-+ "tcp:a.b.c.d/path": "",
- "udp://127.0.0.1": "Invalid bind address format: udp://127.0.0.1",
- "udp://127.0.0.1:2375": "Invalid bind address format: udp://127.0.0.1:2375",
- "tcp://unix:///run/docker.sock": "Invalid proto, expected tcp: unix:///run/docker.sock",
-@@ -83,7 +83,7 @@ func TestParseDockerDaemonHost(t *testing.T) {
- "localhost:5555/path": "tcp://localhost:5555/path",
- }
- for invalidAddr, expectedError := range invalids {
-- if addr, err := parseDaemonHost(invalidAddr); err == nil || err.Error() != expectedError {
-+ if addr, err := parseDaemonHost(invalidAddr); err == nil || expectedError != "" && err.Error() != expectedError {
- t.Errorf("tcp %v address expected error %q return, got %q and addr %v", invalidAddr, expectedError, err, addr)
- }
- }
-@@ -99,8 +99,8 @@ func TestParseTCP(t *testing.T) {
- defaultHTTPHost = "tcp://127.0.0.1:2376"
- )
- invalids := map[string]string{
-- "tcp:a.b.c.d": "Invalid bind address format: tcp:a.b.c.d",
-- "tcp:a.b.c.d/path": "Invalid bind address format: tcp:a.b.c.d/path",
-+ "tcp:a.b.c.d": "",
-+ "tcp:a.b.c.d/path": "",
- "udp://127.0.0.1": "Invalid proto, expected tcp: udp://127.0.0.1",
- "udp://127.0.0.1:2375": "Invalid proto, expected tcp: udp://127.0.0.1:2375",
- }
-@@ -125,7 +125,7 @@ func TestParseTCP(t *testing.T) {
- "localhost:5555/path": "tcp://localhost:5555/path",
- }
- for invalidAddr, expectedError := range invalids {
-- if addr, err := ParseTCPAddr(invalidAddr, defaultHTTPHost); err == nil || err.Error() != expectedError {
-+ if addr, err := ParseTCPAddr(invalidAddr, defaultHTTPHost); err == nil || expectedError != "" && err.Error() != expectedError {
- t.Errorf("tcp %v address expected error %v return, got %s and addr %v", invalidAddr, expectedError, err, addr)
- }
- }